[Issue Report]Regarding Operation Delay / 【障害報告】動作遅延に関して
Incident Report for TableCheck
Postmortem

Date & Time of Occurrence: 23rd October 2021, 10:02am JST
Date & Time of Recovery: 23rd October 2021, 12:12pm JST

【Issue Summary】

● TableCheck Online booking Page
Delays and/or failure to carry out the following actions were experienced:
- TableCheck Portal venue search
- Confirmation of reservations
- Confirmation of payments

● TableCheck Manager
Some users were unable to log into the system or were logged out involuntarily.

【Issue Timeline】

Friday, 22nd October
Server capcities were increased in anticipation of several events, where user access on TableCheck Online booking page was expected to increase.

Saturday, 23rd October
09.55am JST: A larger than expected spike in access is detected, and internal confirmation on the situation is relayed.
10.05am JST: Simultaneous reservations in large numbers are made due to the events. The increased number of reservations caused TableCheck portal venue searches, reservation and payment confirmations to be affected.
10.10am JST: Additional server capacity was added.
10.22am JST: TableCheck portal venue searches, reservation and payment confirmations conditions started to improve.
10.30am JST: Due to the reloading of the database, some TableCheck users faced issues in logging into TableCheck Manager or being logged out involuntarily.
10.36am JST: Measures were taken to improve the performance for TableCheck Manager, easing the issue faced by some users.
10.44am JST: Confirmation that the venue in which was running the event has reached capacity, and took measures to disable the online availabilty of said venue.
12.12pm JST: All systems are stabalized and back to normal was confirmed.

【Cause of Issue】

The issue was primarily caused by an excessive number of access to TableCheck Online booking page, where a large number of simultaneous reservations were being made during a reservation event. Although measures and server capacities were increased in anticipation of the event, the numbers far exceeded what was anticipated.

【Short-term Mitigation】

1. Server capacities were increased to accommodate the access volume.
2. Measures were taken to manually disable the online availability of the venue the event was for, once all seats were sold out.

■ Future Remediation Actions

● Putting in place a program that automatically detects when access has exceeded beyond server capacities on the TableCheck Online booking page, especially when concentrated from a particular venue.
● Looking into ways to prevent a spike faced on TableCheck Online booking page to directly affect TableCheck Manager's stability.

We sincerely apologize for the inconvenience caused to all users, and seek your kind understanding on the matter.

TableCheck Support

**********************************************************************

発生日時:2021.10.23 10:02am
復旧日時:2021.10.23 12:12pm

【内容】

●TableCheckオンラインページ:
下記操作に於いて、動作の遅延、または処理が完了しない事象が発生
ーTableCheckポータル店舗検索
ー予約確定
ー支払確定

●TableCheck管理画面:
一部のお客様にて、ログインできない・強制ログアウトする現象が発生

影響範囲:

・TableCheckオンラインページに於ける店舗検索、予約確定、支払い確定
・TableCheck管理画面

タイムライン:

10月22日(金)
アクセス増加が想定されるイベントの開始に対応する為キャパシティ増加

10月23日(土)
9:55am:通常を上回るアクセスを検知、社内確認開始
10:05:一斉予約受付イベント開催に伴う更なるアクセス数の増加により、TableCheckオンラインページに於ける店舗検索、予約確定、支払い確定機能に影響
10:10:キャパシティ追加増強
10:22:TableCheckオンラインページに於ける店舗検索、予約確定機能が改善
10:30:databaseのロードにより、一部のお客様にて、TableCheck管理画面へログインできない・強制ログアウトする現象が発生
10:36:TableCheck管理画面パフォーマンスへの影響起因を解明、対応を講じる
10:44:予約が満席になった事を確認し、イベント開催店舗様のオンライン機能を強制的に無効とする措置を取る
12:12pm:全機能の通常稼働を確認

【原因】

今回の問題は、一斉予約受付イベントによるアクセス過多の影響を受けたものであり、事前にご提供いただいた情報に基づいてサーバー増強の対策を取っておりました。
しかし増強したキャパシティを超えるアクセスが発生したため全体へ影響を受けるものとなり、結果としてTableCheck管理画面へ影響したものとなります。

【対応】

1)アクセスボリュームをハンドルできるキャパシティへ増強対応をいたしました。
2)該当イベントの予約席が満席になった段階で該当店舗様のオンライン機能を強制的に無効とする対応をいたしました。

■今後の対応

・一部店舗様のTableCheckオンライン機能にキャパシティ以上のアクセスが集中した際は、自動検知して該当店舗様のTableCheckオンライン機能を無効とするシステムの構築
・TableCheckオンライン機能のアクセス過多をTableCheck管理画面へ影響させない機能の構築と調査

ご利用の皆様にはご迷惑をお掛けし、誠に申し訳ございませんでした。

TableCheckサポート

Posted Oct 27, 2021 - 18:16 JST

Resolved
This incident has been resolved. We sincerely apologise for the inconvenience caused to all users.
TableCheck Support

*********************************************

障害は復旧致しました。ご迷惑をおかけし誠に申し訳ございません。
TableCheck Support
Posted Oct 23, 2021 - 11:43 JST
Investigating
Date & Time of Occurrence: 2021-10-23 10:00 JST

[Details]
Currently, a delay is observed on the TableCheck Manager system and online booking page. Some users are unable to login to the system or experienced forced log out.

Affected System:
・TableCheck Manager System
・TableCheck online booking page

Please note that the following features are NOT affected:
・ TableCheck Settings System
・ All other functions (including automatic emails and API integration)


[Cause]
investigating.

Please use Rescue App until the fix is done.You can reach there from the [Rescue App] button on the login page/ session error page.

We sincerely apologize for the inconvenience caused to all users.
TableCheck Support

****************************************************************************

発生日時:2021-10-23 10:00

【内容】
只今、TableCheck管理画面・予約ページ上での動作遅延が発生しております。
一部のお客様においては、ログインできない・強制ログアウトする現象が発生しております。

影響範囲:
・TableCheck管理画面
・TableCheck予約ページ

下記機能は影響しておりません:
・TableCheck設定画面
・その他全ての機能(自動メール送信機能やAPI連携含む)

【原因】
調査中

修正完了まではバックアップサービスをご利用下さいませ。ログイン画面/セッションエラー画面下部の[バックアップサービス]ボタンからリンク可能です。

ご利用の皆様にはご迷惑をお掛けして誠に申し訳ございません。
TableCheckサポート
Posted Oct 23, 2021 - 10:43 JST
This incident affected: TableCheck for Diners and TableCheck for Restaurants.